Show full size 924Board.org
Discussion Forum of 924.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Technical FAQ924 FAQ (Technical)   Technical924 Technical Section   Jump to 924.org924.org   Jump to PCA 924 Registry924 Registry

1977 924 - sudden rough idle and sputtering?

 
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions
View previous topic :: View next topic  
Author Message
pinotdino  



Joined: 07 Jun 2019
Posts: 9
Location: Seattle

PostPosted: Wed Dec 25, 2019 5:14 am    Post subject: 1977 924 - sudden rough idle and sputtering? Reply with quote

Hello 924Board friends, hoping for your expertise and help! Purchased a 77' 924 about 8 months ago (2nd owner) with 73k miles. Because there was not really a paper trail from previous owner, I did some basic stuff to know where they stood: timing belt, water pump, fuel filter, air filter, new plugs, distributor cap, rotor and oil change. As well as looked over hoses and because it has a slight hesitation, I removed the injectors to inspect and try and clean. It has run strong, idles at 900 and starts cold or hot. .. until yesterday.

I took it out for a casual drive and all ran well UNTIL I got premium gas at our local station (the gas light had just come on, previous take was non-ethonol). It now jumps around at idle (not dying, just stumbles) and then when giving throttle, it sputters till it gets to about 2500 - 3000 rpms, after this it runs great. Any help with a direction would be great. Thanks!
Back to top
View user's profile Send private message
pinotdino  



Joined: 07 Jun 2019
Posts: 9
Location: Seattle

PostPosted: Mon Dec 30, 2019 2:46 am    Post subject: Update - fixed. Reply with quote

Update - I decided it may be a fuel related issue so I just removed all 4 of the injectors, checked the o rings, tapped the injectors to hopefully remove any possible debris and wiped as clean as I could. Reinstalled and checked lines. It started right up and idled right at the 900 rpms mark as it always has. No more sputtering and back to running strong. I did also find a vacuum line that had slipped off and corrected that as well. Drove on a nice 40 mile winding mountain road and back with it running perfect!
Back to top
View user's profile Send private message
Fasteddie313  



Joined: 29 Sep 2013
Posts: 2037
Location: MI

PostPosted: Mon Dec 30, 2019 6:00 am    Post subject: Reply with quote

Good job!

Sorry you didn't get any help but I didn't have any good ideas based on your reported symptoms..
_________________
80 Turbo - Slightly Modified
Back to top
View user's profile Send private message Yahoo Messenger
safe  



Joined: 18 Mar 2017
Posts: 171
Location: Sweden

PostPosted: Mon Dec 30, 2019 8:08 pm    Post subject: Reply with quote

Change the fuel filter, cut the old one open to see if it caught anything nasty.
Back to top
View user's profile Send private message
pinotdino  



Joined: 07 Jun 2019
Posts: 9
Location: Seattle

PostPosted: Fri Jan 03, 2020 3:27 am    Post subject: Reply with quote

safe wrote:
Change the fuel filter, cut the old one open to see if it caught anything nasty.


Thank you and good idea. Despite the fuel filter only being a few months old, it could have caught debris meaning the tank might need a cleaning. Cheers.
Back to top
View user's profile Send private message
pinotdino  



Joined: 07 Jun 2019
Posts: 9
Location: Seattle

PostPosted: Fri Jan 03, 2020 4:23 am    Post subject: Reply with quote

Fasteddie313 wrote:
Good job!

Sorry you didn't get any help but I didn't have any good ideas based on your reported symptoms..


Update: Jan 19 - bought 4 new fuel injectors/o-rings and installed in like 10 mins.. the 924 runs perfectly now with no hesitation! So smooth on the gas from starting to highway speeds. So great!

Thanks.. just one of those symptoms I guess. Seemed it got quite a few views. Drove again this week with it running strong. I still have a very, very slight hesitation in all gears which Iím starting to think it could be the old injectors. May replace in the next month as I think they are the originals.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions All times are GMT + 10 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group