Show full size 924Board.org
Discussion Forum of 924.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Technical FAQ924 FAQ (Technical)   Technical924 Technical Section   Jump to 924.org924.org   Jump to PCA 924 Registry924 Registry

Excessive vibration at high RPM

 
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions
View previous topic :: View next topic  
Author Message
Juhana  



Joined: 30 Mar 2018
Posts: 4
Location: Turku, Finland

PostPosted: Wed Jul 18, 2018 6:55 am    Post subject: Excessive vibration at high RPM Reply with quote

Hi need your help guys,

I was on a nice evening drive when I unexpectedly hit a bump in the road pretty hard. My car is low and running coilovers so parts of the underside probably hit the road when i ran into the bump. After the bump I started noticing excessive vibration at high rpm. I drove home slowly and lifted the car. The underside seems fine and nothing seems to have come loose. What could be causing the vibration? Exhaust is fine and has not come loose. Could this be a result of failed engine mounts?

My car is a 1985 924 2.0


Thanks in advance
Back to top
View user's profile Send private message
Fifty50Plus  



Joined: 28 Feb 2008
Posts: 1008
Location: Washington DC area

PostPosted: Wed Jul 18, 2018 11:00 am    Post subject: Reply with quote

bent wheel.
_________________
1979 924 NA race car
1982 924 NA race car - Sold
1982 924 Turbo almost a PoS
1981 924 Turbo a real PoS, new engine
1982 924 Turbo nice body, blown engine
1972 911 E race car - going to Vintage
Various 944s to become IT-S race car
Back to top
View user's profile Send private message
Ian89C4  



Joined: 01 Apr 2011
Posts: 536
Location: North Carolina

PostPosted: Wed Jul 18, 2018 9:26 pm    Post subject: Reply with quote

Bent wheel or a blown tie rod end I would say. Doubt that would destroy a motor mount.

With a bad motor mount you will feel it more at idle, and you will hear the exhaust banging on the torque tube tunnel. Just had to replace mine on the 931 and those were the symptoms.

Good luck.
_________________
Ian Edgerly
Spiveys Corner, North Carolina

Current:
1981 924 Weissach Race Car ("Serenity")
1980ish 931 ("Alice")
Back to top
View user's profile Send private message Visit poster's website
Juhana  



Joined: 30 Mar 2018
Posts: 4
Location: Turku, Finland

PostPosted: Thu Jul 19, 2018 7:11 am    Post subject: Reply with quote

Found the problem. The impact did indeed crack one of the motor mounts. The mount must have been on itīs way out already for that to happen. Easy enough fix thank god.
Back to top
View user's profile Send private message
Ian89C4  



Joined: 01 Apr 2011
Posts: 536
Location: North Carolina

PostPosted: Sat Jul 21, 2018 11:22 pm    Post subject: Reply with quote

Well I'll be darned. Good spot!

Glad it's an easy fix.
_________________
Ian Edgerly
Spiveys Corner, North Carolina

Current:
1981 924 Weissach Race Car ("Serenity")
1980ish 931 ("Alice")
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions All times are GMT + 11 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group