Show full size 924Board.org
Discussion Forum of 924.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Technical FAQ924 FAQ (Technical)   Technical924 Technical Section   Jump to 924.org924.org   Jump to PCA 924 Registry924 Registry

Fuel relay question

 
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions
View previous topic :: View next topic  
Author Message
immerohnegott  



Joined: 06 Nov 2019
Posts: 4
Location: Indiana, USA

PostPosted: Thu Nov 28, 2019 1:50 am    Post subject: Fuel relay question Reply with quote

Hey folks,

Just started my first project car - '80 924 N/A - and I've got (surprise) a cold start issue. Before testing for trouble with the CIS system / WUR / idle air valve / etc, I have a quick question on the fuel pump relay since I noticed something trying to start her up this morning. When cranking, the relay clicks but I can't hear the pump run. Thankfully, said pump is loud enough you can hear it from the driver's seat which aids my troubleshooting a bit.

It does run for a second or two after ignition is cut back off, and once the car eventually stumbles to life it seems to at least run the pump consistently. Is this normal behavior? I feel like the relay should engage the pump while the starter is being turned, no?

Basically: Turn key, relay clicks a couple times but no sound from pump, stop cranking and the pump runs a couple seconds. From what I've read here, the pump relay is activated by a tach signal from the coil. This works, tach bounces when cranking and the gauge works when car is running, although it's an aftermarket MSD coil.

With the pump being as loud as it is (no weird grinding noises, just louder than I would expect), I'm sure it's on the way out but I haven't flowtested just yet. The car does run and drive once it gets turned over and warmed up, at least.
Back to top
View user's profile Send private message
immerohnegott  



Joined: 06 Nov 2019
Posts: 4
Location: Indiana, USA

PostPosted: Thu Nov 28, 2019 12:16 pm    Post subject: Reply with quote

Nevermind, I'm deaf and / or an idiot. Dug into it a bit more after work and the relay seems to be working as intended with the pump spinning during ignition crank. Apologies, please disregard the previous post
Back to top
View user's profile Send private message
morghen  



Joined: 21 Jan 2005
Posts: 8177
Location: Romania

PostPosted: Thu Nov 28, 2019 5:55 pm    Post subject: Reply with quote

make sure the pump is actually putting out fuel at the fuel dizzy.
_________________
Ruby-sh 924
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger
immerohnegott  



Joined: 06 Nov 2019
Posts: 4
Location: Indiana, USA

PostPosted: Fri Nov 29, 2019 12:23 am    Post subject: Reply with quote

Oh certainly. I need to make a jumper switch for the relay and flowtest it at the distributor inlet anyway - I just thought I had an electrical problem compounding things
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    924Board.org Forum Index -> General Discussions All times are GMT + 10 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group