Show full size 924Board.org
Discussion Forum of 924.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 Technical FAQ924 FAQ (Technical)   Technical924 Technical Section   Jump to 924.org924.org   Jump to PCA 924 Registry924 Registry

Oil Pressure light - random flickering

 
Post new topic   Reply to topic    924Board.org Forum Index -> 924S Discussions
View previous topic :: View next topic  
Author Message
mikseymono1  



Joined: 08 Feb 2019
Posts: 1
Location: Brittany, France

PostPosted: Fri Feb 08, 2019 6:45 pm    Post subject: Oil Pressure light - random flickering Reply with quote

SO, oil pressure light on the instrument cluster (oil can picture) has been flickering over the last couple of weeks. Not a constant blink like an indicator, more like a random flicker….sometimes a hard red…sometimes a soft one…..like an electrical problem. Have not used car much in the last month…weather…maybe four 10 min journeys at best….yesterday, I changed the Oil (Castrol GTX Ultraclean 10w40) OEM oil filter and put on a brand new OEM Oil Pressure sender. Oil pressure on cold starts pegged at 5 then after 15 mins it goes to around 3.4 on idle…so not far off Clarks guide.
Took it for a spin today…upon start the oil pressure goes to 5 and sure enough the oil pressure light starts to flicker……after 3 mins…light goes away…drive for another 15 mins….light flickered once during this time and that was it.
So…a bit strange. I can’t seem to get it to come on with acceleration/braking etc..it has a mind of its own...I have checked wires from sender and ensured good contact to the sender to both the connections and have also checked back to under the manifold area. I have an oil level sender on the sump and the wires look ok…but unsure how to test that.

So, a bit strange and random. It really seems electrical rather than a mechanical fault…just can’t trace it. I guess in the grand scheme of things if the car is pulling well, with good oil pressure, no obvious leaks all is OK…just this flickering light is annoying...

Any pointers greatly appreciated.

Cheers,

M
_________________
9242 - 1988
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    924Board.org Forum Index -> 924S Discussions All times are GMT + 11 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group